13 августа 2020, 17:29

Цитата дня:

Праздник нужно всегда носить с собой. Эрнест Хемингуэй


User Profile Disks – не работает меню «Пуск»

Автор STALKER_SLX, 22 февраля 2020, 19:50

« предыдущая тема - следующая тема »

0 Пользователей и 1 Гость просматривают эту тему.

Вниз

STALKER_SLX

22 февраля 2020, 19:50 Последнее редактирование: 22 февраля 2020, 19:52 от STALKER_SLX
Доброго времени суток уважаемые форумчане!

1. Имеем свежеустановленный «Windows Server 2019 Standard», который введён в домен.
2. На нем поднята служба удалённых рабочих столов.
3. Настроил, чтобы профили пользователей сохранялись на отдельных виртуальных дисках - «User Profile Disks в RDS Windows Server». Делал по этой статье:
https://winitpro.ru/index.php/2015/04/28/user-profile-disks-v-rds-windows-server-2012/

4. В моем конкретном случае был реализован «второй вариант» из указанной статьи, а именно, чтобы на дисках сохранялись только избранные папки пользовательского профиля («Рабочий стол», «Документы», «Загрузки», «Изображения», «Данные перемещаемого профиля пользователя» и «Данные реестра пользователя»).

Но вот после применения настроек для «User Profile Disks» и перезагрузке сервера, в меню «Пуск» исчезли иконки (в том числе и плитки) и перестало работать вовсе. Для лучшего понимания данной ситуации, привожу скриншот ("start_menu_absent_icons.png")
Гугление по этой теме не принесло результатов по исправлению указанного бага…

Как временное решение (костыль) был написан скрипт, который перезапускает службу/процесс «Проводник» (Explorer) и добавлен в автозагрузку. Эта идея была позаимствована вот тут:

«Что делать, если не работает Пуск в Windows 10»
https://internetua.com/csto-delat-esli-ne-rabotaet-pusk-v-windows-10

Прошу Вашей помощи разобраться в этом непростом для меня вопросе!

Уваров А.С.

4. В моем конкретном случае был реализован «второй вариант» из указанной статьи, а именно, чтобы на дисках сохранялись только избранные папки пользовательского профиля («Рабочий стол», «Документы», «Загрузки», «Изображения», «Данные перемещаемого профиля пользователя» и «Данные реестра пользователя»).
На мой взгляд проблема кроется где-то в этом. Попробуйте сначала с полным профилем, а потом уже исключайте из него директории.

STALKER_SLX

Спасибо за помощь - разобрался!
Был немного не внимательным и пытался в настройках указать локальный путь к папке с VHD-дисками!
А нужно было сделать следующее для решения описанной выше проблемы.

1. Даем полные права на папку с VHD-дисками (с профилями пользователей) текущему ТЕРМИНАЛЬНОМУ серверу (в нашем случае - «RD01»)

2. Отрываем сетевой доступ к папке с дисками и выставляем в закладке «Безопасность» доступ только терминальному серверу (в нашем случае - «RD01»)

3. В настройках коллекции монтируем указанную папку с VHD-дисками как сетевой ресурс, например так, - \\RD01\VHD

Вверх